not enough additional bytes in response

Installation and Usage Support
Post Reply
Feichtl
Posts: 2
Joined: March 2nd, 2020, 6:50 am

not enough additional bytes in response

Post by Feichtl »

Hi there,

tried to install VersaTune on my Mazda MX-5 ND (MK4). After updating Versa Tuner to latest version, that supports my ECU, i get following error:

not enough additional bytes in response

I#m using the suggested OBDLink SX cable. Are there special settings for the com-port, that might cause this error?

Thx for any help.

Werner
VersaTuneError.jpg
VersaTuneError.jpg (270.04 KiB) Viewed 2976 times
User avatar
Ugnius @ VersaTune
Lead developer
Posts: 458
Joined: March 19th, 2010, 11:57 am

Re: not enough additional bytes in response

Post by Ugnius @ VersaTune »

As we diagnosed by email, this seems to be a driver issue. OBDLink SX usually doesn't require any special drivers and works fine with the drivers that are built in Windows 10. There seems to be some configuration that prevents OBDLink SX from working normally for some users. We have not yet identified what exactly needs to be changed to fix the issue, but usually everything works fine on a freshly installed PC.
Feichtl
Posts: 2
Joined: March 2nd, 2020, 6:50 am

Re: not enough additional bytes in response

Post by Feichtl »

Solved, before approved in the forum. It's been a driver issue on my notebook. Installed everything on another notebook and it worked.

If someone else has the same problem: Either you can fix the driver problem or change the notebook (or whatever you use)

By the way: outstanding support by @Ugnius!
Dudevo
Posts: 1
Joined: March 21st, 2021, 7:09 am

Re: not enough additional bytes in response

Post by Dudevo »

I only have one notebook, so how do I solve the driver issue? Is there a way to reinstall them.
Post Reply